Which of my devices are compatible with Android Pay?

Frequently Asked Question

You can use Android Pay with your NFC-enabled device running Android OS 4.4 (KitKat) or higher.

Become a Citadel Member, today!